MIKROTIK

Hybrid VLAN di CRS 1xx/2xx

Ada beberapa metode yang bisa digunakan pada CRS 1xx/2xx untuk melakukan managment VLAN. Salah satu contoh yang akan kita bahas disini adalah ‘Trunk & Hybrid Ports’. Metode ini merupakan salah satu metode dari Port Based VLAN yang ada di CRS.

Pada artikel sebelumnya juga sudah dibahas bagaimana management VLAN menggunakan metode Port Based VLAN, yaitu ‘Trunk & Access Ports’. Lalu, apa perbedaan antara ‘Trunk & Access Ports’ dengan ‘Trunk & Hybrid Ports’?

Secara umum untuk ‘Trunk & Access Ports’ ketika interface ethernet dari CRS yang disetting sebagai Access port akan hanya ada Untagged VLAN-ID saja sedangkan ‘Trunk & Hybrid Port’ akan bercampur antara Untagged VLAN-ID dan Tagged VLAN-ID.

Konfigurasi

Sebagai contoh konfigurasi, kita akan mencoba melakukan konfigurasi seperti pada gambar topologi diatas. Terlihat pada gambar topologi tersebut interface ethernet yang menjadi Access Port masih membawa informasi Tagged VLAN-ID.

Dengan kondisi seperti itu kita bisa membuat koneksi dengan adanya VLAN-ID pada perangkat yang tersambung ke Access-Port di switch CRS. Misal, seperti di topologi pada port 2-8 di CRS terdapat Untagged VLAN-ID 10, namun jika dibutuhkan koneksi baru untuk distribusi VLAN-ID 20 & VLAN-ID 30 melalui port 2-8 tersebut, kita bisa menambahkan perangkat switch manageable lagi dibawahnya.

Langkah pertama, kita akan konfigurasi interface pada CRS kedalam mode bridge.

/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether1 hw=yes
add bridge=bridge1 interface=ether2 hw=yes
add bridge=bridge1 interface=ether3 hw=yes
add bridge=bridge1 interface=ether4 hw=yes

Langkah kedua, kita akan melakukan konfigurasi untuk memberikan VLAN-ID pada setiap trafik yang masuk melalui access port. Konfigurasi ini dilakukan pada menu ‘Switch –> VLAN –> In. VLAN Tran.

/interface ethernet switch ingress-vlan-translation
add ports=ether2 customer-vid=0 new-customer-vid=10
add ports=ether3 customer-vid=0 new-customer-vid=20
add ports=ether4 customer-vid=0 new-customer-vid=30

Langkah ketiga, kita juga akan membuat setiap trafik yang keluar dari port-port baik Trunk dan juga Access Port ditambahkan informasi VLAN-ID yang sesuai dengan topologi diatas untuk membuat tagged VLAN-ID. Hal ini dilakukan pada menu ‘Switch –> VLAN –> Eg. VLAN Tag‘.

Dan disini yang membedakan konfigurasi dari metode ‘Trunk & Access Port‘ dengan ‘Trunk & Hybrid Port‘ yaitu pada metode ‘Trunk & Access Port‘ untuk konfigurasi tagged VLAN-ID di setiap trafik yang keluar (Egress) hanya dilakukan pada interface ethernet yang menjadi Trunk Port saja sedangkan ‘Trunk & Hybrid Port‘ untuk tagged VLAN-ID juga disetting pada Access Port.

/interface ethernet switch egress-vlan-tag
add tagged-ports=ether1,ether3,ether4 vlan-id=10
add tagged-ports=ether1,ether2,ether4 vlan-id=20
add tagged-ports=ether1,ether2,ether3 vlan-id=30

Langkah keempat, kita juga akan menambahkan informasi VLAN-ID pada tabel VLAN di CRS. Dan disini untuk VLAN-ID disetting pada masing-masing ethernet yang akan digunakan untuk management VLAN, baik pada Trunk Port maupun Access Port.

Konfigurasi ini dilakukan pada menu ‘Switch –> VLAN –> VLAN‘.

/interface ethernet switch vlan
add ports=ether1,ether2,ether3,ether4 vlan-id=10 learn=yes
add ports=ether1,ether2,ether3,ether4 vlan-id=20 learn=yes
add ports=ether1,ether2,ether3,ether4 vlan-id=30 learn=yes

*) NOTE:

Selain konfigurasi diatas, kita juga bisa menambahkan Unknown/VLAN Filtering untuk proteksi supaya trafik yang masuk hanya trafik yang menggunakan VLAN-ID yang terdaftar di tabel VLAN.

Konfigurasi ada di menu ‘Switch –> Settings –> Drop If Invalid VLAN On Ports‘. Dan konfigurasinya seperti dibawah ini.

/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports=ether2,ether3,ether4

Kita akan proteksi trafik masuk dari masing-masing interface ethernet CRS yang menjadi Access Port.