MIKROTIK

MAC Based VLAN di CRS 1xx/2xx

Pada artikel sebelumnya sudah dibahas mengenai konfigurasi dari ‘Trunk & Hybrid Ports’ di CRS 1XX/2XX series. Selanjutnya di artikel ini kita akan mencoba metode management VLAN yang lain, yaitu MAC Based VLAN.

Berbeda dengan cara sebelumnya untuk MAC Based VLAN ini nanti, untuk Untagged VLAN berdasarkan MAC-Address dari perangkat end-device dan tidak lagi berdasarkan port dari perangkat switchnya. Sehingga di port manapun perangkat end-device terkoneksi maka tetap akan mendapatkan akses jaringan berdasarkan untagged VLAN yang disesuiakan dengan MAC-Address perangkat.

Konfigurasi

Sebagai contoh disini ada gambaran topologi dimana nanti kita akan konfigurasi CRS 1xx/2xx untuk kebutuhan MAC Based VLAN.

Pertama, Kita akan menjadikan setiap interface ethernet di switch CRS menjadi satu broadcast domain yang sama atau satu segment . Seperti biasa kita akan menggunakan konfigurasi ‘Bridge’.

/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether1 hw=yes
add bridge=bridge1 interface=ether2 hw=yes
add bridge=bridge1 interface=ether3 hw=yes
add bridge=bridge1 interface=ether4 hw=yes
...dst.

Kedua, Kita akan mengaktifkan fungsi ‘MAC Based VLAN Translation‘ di setiap interface ethernet yang nantinya akan dijadikan sebagai Access Port dan terkoneksi ke setiap perangkat end-device. Fungsi ini bisa kita setting pada menu Switch –> Ports.

/interface ethernet switch port
set ether2 allow-fdb-based-vlan-translate=yes
set ether3 allow-fdb-based-vlan-translate=yes
...dst.

Ketiga, Kita akan melakukan mapping antara MAC-to-VLAN dan membuat daftarnya pada Tab MAC Based VLAN di menu Switch CRS 1xx/2xx.

/interface ethernet switch mac-based-vlan
add src-mac=0C:98:38:0A:58:D9 new-customer-vid=10
add src-mac=4C:5E:0C:FE:0A:5F new-customer-vid=20
add src-mac=74:4D:28:9D:BD:58 new-customer-vid=30
... dst.

Keempat, Langkah terakhir kita akan membuat juga konfigurasi ‘Egress-Vlan-Tag‘ yang akan digunakan pada interface ethernet yang menjadi Trunk Port.

/interface ethernet switch egress-vlan-tag
add tagged-ports=ether1 vlan-id=10
add tagged-ports=ether1 vlan-id=20
add tagged-ports=ether1 vlan-id=30